一.简介
本系列是用来分享在洛谷,LeetCode的有趣的题目,使用Java编写且代码解释以注释为主。
本篇涉及:输入输出,if判断,for循环,方法(即函数),数组,AscII码
二.题目
【深基2.例6】字母转换
题目描述
输入一个小写字母,输出其对应的大写字母。例如输入 q[回车] 时,会输出 Q。
输入格式
无
输出格式
无
样例 #1
样例输入 #1
样例输出 #1
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
|
import java.util.*;
class Main { public static void main(String args[]) throws Exception { Scanner cin = new Scanner(System.in); char a = cin.next().charAt(0); cin.close(); System.out.println((char) (a - 'a' + 'A')); } }
|
【深基2.例7】数字反转
题目描述
输入一个不小于 $100$ 且小于 $1000$,同时包括小数点后一位的一个浮点数,例如 $123.4$ ,要求把这个数字翻转过来,变成 $4.321$ 并输出。
输入格式
一行一个浮点数
输出格式
一行一个浮点数
样例 #1
样例输入 #1
样例输出#1
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
| import java.util.*;
class Main { public static void main(String args[]) throws Exception { Scanner cin = new Scanner(System.in); String str = cin.nextLine(); cin.close(); for (int i = str.length(); i > 0; i--) {
System.out.print(str.charAt(i - 1)); } } }
|
题目描述
给出三个整数 $a,b,c(0\le a,b,c \le 100)$,要求把这三位整数从小到大排序。
输入格式
输入三个整数 $a,b,c$,以空格隔开。
输出格式
输出一行,三个整数,表示从小到大排序后的结果。
样例 #1
样例输入 #1
样例输出 #1
样例 #2
样例输入 #2
样例输出 #2
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
|
import java.util.*;
class Main { public static void main(String args[]) throws Exception { Scanner cin = new Scanner(System.in); int a = cin.nextInt(); int b = cin.nextInt(); int c = cin.nextInt(); cin.close(); if (a > b) { int temp = a; a = b; b = temp; } if (b > c) { int temp = b; b = c; c = temp; } if (a > b) { int temp = a; a = b; b = temp; } System.out.println(a + " " + b + " " + c); } }
|
题目描述
输入年份和月份,输出这一年的这一月有多少天。需要考虑闰年。
输入格式
输入两个正整数,分别表示年份 $y$ 和月数 $m$,以空格隔开。
输出格式
输出一行一个正整数,表示这个月有多少天。
样例 #1
样例输入 #1
样例输出 #1
样例 #2
样例输入 #2
样例输出 #2
提示
数据保证 $1582 \leq y \leq 2020$,$1 \leq m \leq 12$。
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
| import java.util.*;
class Main { public static void main(String args[]) throws Exception { Scanner cin = new Scanner(System.in); int year = cin.nextInt(); int month = cin.nextInt(); cin.close(); int[] days = { 31, isleap(year) ? 29 : 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31 }; System.out.println(days[month - 1]); }
public static boolean isleap(int year) { return (year % 4 == 0 && year % 100 != 0) || (year % 400 == 0); } }
|